Cisco ASA Upgrade Path and Memory Requirements

29. September 2015 Cisco ASA 4,864

See the following table for the upgrade path for your version. Some versions require an interim upgrade before you can upgrade to the latest version.

Current ASA Version
First Upgrade to:
Then Upgrade to:

8.2(x) and earlier

8.4(6)

9.2(1) or later

8.3(x)

8.4(6)

9.2(1) or later

8.4(1) through 8.4(4)

8.4(6), 9.0(4), or 9.1(2)

9.2(1) or later

8.4(5) and later

9.2(1) or later

8.5(1)

9.0(4) or 9.1(2)

9.2(1) or later

8.6(1)

9.0(4) or 9.1(2)

9.2(1) or later

9.0(1)

9.0(4) or 9.1(2)

9.2(1) or later

9.0(2) or later

9.2(1) or later

9.1(1)

9.1(2)

9.2(1) or later

9.1(2) or later

9.2(1) or later

 

As additional software feature enhancements are introduced on the Cisco®ASA 5500 Series Adaptive Security Appliances, the minimum memory requirements are changing for the Cisco ASA 5505, ASA 5510, ASA 5520, and ASA 5540 models. These requirements are for software releases starting with the Cisco ASA Software Version 8.3. Cisco ASA appliances running Cisco ASA 8.3 that do not meet the minimum memory requirement are not supported. Table 1 outlines the new and existing RAM requirements. Note that the memory requirements for the Cisco ASA 5550 and ASA 5580 have not changed.

 

Cisco ASA Model

Minimum RAM Requirements (pre Cisco ASA 8.3)

Minimum RAM Requirements (post Cisco ASA 8.3)

Default Shipping RAM on New Cisco ASA Adaptive Security Appliances (as of Feb. 2010)

5505 10-User

256 MB

256 MB

512 MB

5505 50-User

256 MB

256 MB

512 MB

5505 Unlimited-User

256 MB

512 MB

512 MB

5505 Security Plus

256 MB

512 MB

512 MB

5510

256 MB

1 GB

1 GB

5510 Security Plus

256 MB

1 GB

1 GB

5520

512 MB

2 GB

2 GB

5540

1 GB

2 GB

2 GB

5550

4 GB

4 GB

4 GB

5580-20

8 GB

8 GB

8 GB

5580-40

12 GB

12 GB

12 GB

ASA Failover Configuration


Leave a Reply